DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Range Rover - Technical Discussions

Reply
 
Thread Tools Display Modes
Old 07-11-2010, 01:41 AM   #1
syugg
Member
 
syugg's Avatar
 
Join Date: Mar 2007
Location: San Jose, CA
Posts: 82
Default 40A Fuse Keeps Blowing- Starter Motor & Air Suspension - HELP

The 40 amp fuse located in the engine compartment keeps blowing in my 2002 P38. This fuse is for the starter motor and air suspension.

I had replaced the air compressor with a rebuilt one less than 6 months ago. The air compressor feels hot even after parking the truck for 4 hours and it has somewhat of a burnt smell. The car is riding on its bump stops.

Anybody have any thoughts as to the issues or how to troubleshoot what is causing the blown fuse? Please help!!
syugg is offline   Reply With Quote
Old 07-11-2010, 02:22 PM   #2
ptschram
Encyclopaedia Brown
 
ptschram's Avatar
 
Join Date: Sep 2004
Location: In a Snap-On truck somewhere around Churubusco, IN
Posts: 21,086
Default Re: 40A Fuse Keeps Blowing- Starter Motor & Air Suspension - HELP

Disconnect the compressor and check to see if it still blows fuses.

Does it do it immediately, or when the compressor kicks on, or when you try to start it?
ptschram is offline   Reply With Quote
Old 07-12-2010, 12:48 AM   #3
syugg
Member
 
syugg's Avatar
 
Join Date: Mar 2007
Location: San Jose, CA
Posts: 82
Default Re: 40A Fuse Keeps Blowing- Starter Motor & Air Suspension - HELP

Doesn't blow when I disconnect the compressor. Could it be that the compressor has seized? If so what would be the cause?
syugg is offline   Reply With Quote
Old 07-12-2010, 02:40 PM   #4
ptschram
Encyclopaedia Brown
 
ptschram's Avatar
 
Join Date: Sep 2004
Location: In a Snap-On truck somewhere around Churubusco, IN
Posts: 21,086
Default Re: 40A Fuse Keeps Blowing- Starter Motor & Air Suspension - HELP

Poor rebuild.

If the rebuilder doesn't make it right, I can get a new one for you.
ptschram is offline   Reply With Quote
Old 07-14-2010, 02:14 AM   #5
syugg
Member
 
syugg's Avatar
 
Join Date: Mar 2007
Location: San Jose, CA
Posts: 82
Default Re: 40A Fuse Keeps Blowing- Starter Motor & Air Suspension - HELP

You were right PT and thanks. It turns out the re-manufactured compressor went bad. The good thing is that Rover Renovations has a 1 yr warranty on the compressor. The bad is that they required verification from my mechanic (1 hour labor at $135/hr) in order to honor the warranty.
syugg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dry thread Discovery series 1 ac info Chris-St Louis Discovery - Technical Discussions 2 08-25-2005 10:51 AM
Need help with ECU fuse blowing! Gordo Range Rover - Technical Discussions 1 06-28-2005 07:04 PM
How often should my air suspension compressor operate? BrettinSanAntonio Range Rover - Technical Discussions 3 12-04-2004 11:36 AM
Questions on Air Suspension for '04 HSE CARBON110 Discovery - Technical Discussions 3 09-14-2004 10:01 PM


All times are GMT -4. The time now is 06:29 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ?2000 - 2013, DiscoWeb LLC. All rights reserved.