DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Discovery - Technical Discussions

Reply
 
Thread Tools Display Modes
Old 06-23-2008, 07:25 PM   #1
mdursa
Member
 
mdursa's Avatar
 
Join Date: Sep 2005
Location: NOLA, 10 feet downhill of the mighty Mississippi
Posts: 158
Default P1176 - I searched already

98 Disco 1 LSE. 138k. CEL on with P1176 code-Maximum Positive FMFR Correction Fault .

No problems, truck runs great except an occasional (one morning every 2 weeks) high idle.

I've reset the code, it takes about a week to come back.

What specific steps to troubleshoot? Thanks.
__________________
No one ever accused me of being smart.
mdursa is offline   Reply With Quote
Old 06-23-2008, 08:14 PM   #2
OFFROVER
Member
 
OFFROVER's Avatar
 
Join Date: Dec 2005
Location: Knoxville,TN
Posts: 262
Default Re: P1176 - I searched already

Replace the mass air flow sensor.
__________________
~Corey
96 DI 4.6 5"lift RoverTracksAxles ARB'S w/4.75s 35''BFGKM2's HLC FAB ft/rr whinch bumpers
05 LR3
04 DII SOLD
95 RangeRover SOLD
OFFROVER is offline   Reply With Quote
Old 06-23-2008, 09:29 PM   #3
mdursa
Member
 
mdursa's Avatar
 
Join Date: Sep 2005
Location: NOLA, 10 feet downhill of the mighty Mississippi
Posts: 158
Default Re: P1176 - I searched already

while I agree that the MAF is probably the culprit, it that the first and only thing you would try?
__________________
No one ever accused me of being smart.
mdursa is offline   Reply With Quote
Old 06-23-2008, 09:33 PM   #4
flyfisher11
Member
 
flyfisher11's Avatar
 
Join Date: May 2005
Location: Wolf Laurel NC
Posts: 8,676
Default Re: P1176 - I searched already

He's a master tech with LR. I bet he's right.
__________________
Y2KD2
95 RRC
flyfisher11 is offline   Reply With Quote
Old 06-23-2008, 09:36 PM   #5
mdursa
Member
 
mdursa's Avatar
 
Join Date: Sep 2005
Location: NOLA, 10 feet downhill of the mighty Mississippi
Posts: 158
Default Re: P1176 - I searched already

I agree he is most likely right. I knew it was probably the MAF when I posted. Just thought there might be a few cheaper alternatives to try first.
__________________
No one ever accused me of being smart.
mdursa is offline   Reply With Quote
Old 06-23-2008, 09:40 PM   #6
flyfisher11
Member
 
flyfisher11's Avatar
 
Join Date: May 2005
Location: Wolf Laurel NC
Posts: 8,676
Default Re: P1176 - I searched already

Quote:
Originally Posted by mdursa
I agree he is most likely right. I knew it was probably the MAF when I posted. Just thought there might be a few cheaper alternatives to try first.
Do you know anyone else with a DI? See if they'll let you try theirs for awhile to confirm. If not the best price is Will Tillery aka www.roverguy.com and is highly recommended. Call him though. He's a busy guy but has a cell phone glued to his head.

Good Luck,

Mike
__________________
Y2KD2
95 RRC
flyfisher11 is offline   Reply With Quote
Old 06-23-2008, 09:51 PM   #7
mdursa
Member
 
mdursa's Avatar
 
Join Date: Sep 2005
Location: NOLA, 10 feet downhill of the mighty Mississippi
Posts: 158
Default Re: P1176 - I searched already

I know some people have had success with brake cleaner or carb cleaner, has anyone used CRC MAF cleaner?

http://www.autobarn.net/maairflsecl1.html
__________________
No one ever accused me of being smart.
mdursa is offline   Reply With Quote
Old 06-24-2008, 01:40 AM   #8
Butch
Member
 
Butch's Avatar
 
Join Date: Mar 2006
Location: Warner Robins, Ga
Posts: 427
Default Re: P1176 - I searched already

I used some several moths ago. Everything was running smooth, but I used it as a preventative maintenance and it seemed to clean the MAF up a bit. That reminds me, I should probable hit mine up again, I'm starting to run a little rough.
__________________
98 D1 LE
Butch is offline   Reply With Quote
Old 03-20-2014, 11:54 AM   #9
Brockflock
Almost There...
 
Brockflock's Avatar
 
Join Date: Feb 2008
Location: Fairport, NY
Posts: 42
Default Re: P1176 - I searched already

MDRUSA: Did you find your culprit? Having exact same issues. Was wondering if you got it solved.

Thanks.
__________________
Owner of 1999 D1 - Stock
Brockflock is offline   Reply With Quote
Old 03-20-2014, 01:49 PM   #10
SGaynor
Member
 
SGaynor's Avatar
 
Join Date: Dec 2006
Location: Apex, NC/Bristol, TN
Posts: 2,518
Default Re: P1176 - I searched already

Considering it was almost 6 years ago, he either got it fixed or burned it to the ground.

__________________
Scott

'03 HSE
Go Hokies! - Ut Prosim
SGaynor is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stainless EE brake lines - searched - new question? Roving Beetle Discovery - Technical Discussions 4 04-08-2008 11:40 PM
d2 2" lift questions...I SEARCHED ss1ski Discovery - Technical Discussions 8 03-09-2008 09:32 PM
Another Coolant leak, and yes I searched Robert Alley Discovery - Technical Discussions 14 02-28-2007 08:59 AM
I Have Searched!!!!!! Badfysh Discovery - Technical Discussions 11 11-17-2006 09:25 PM
P1176 Code - CE light goes on & off... MotoBando Discovery - Technical Discussions 6 09-07-2005 12:19 PM


All times are GMT -4. The time now is 01:21 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ?2000 - 2013, DiscoWeb LLC. All rights reserved.